D'Arcy from Winnipeg
Solution Architecture, Business & Entrepreneurship, Microsoft, and Adoption

Infragistics Installation on Vista

Sunday, July 8, 2007 7:30 AM

I had to install the latest Infragistics ASP.NET suite of controls for testing, but ran into an odd problem: every time I went to install, I'd get an error right at the end telling me very ambiguously that there was a "fatal error" and that the "product wasn't installed due to an error". Great...thanks.

Doing what any other good geek would do, I began to investigate this obvious issue with Infragistics and Vista online, hunting for any article that could shed some light on what the obscure error codes that MSIExec was throwing out meant.

I came across this post that had alot of varied info on the issue, but also included a great tip from Steve Palmer on how to get a log file written out for an MSI installation via the commandline:

msiexec.exe /i product.msi /l* c:\log file name.txt

Unfortunately, the output didn't really help me other than to show that right at the end it was erroring and rolling back the install.

Frustrated, I started to wonder if this was an issue with permissions...dammit, there must be something on the Infragistics site for this...there has to be someone who came accross this issue before...

As I'm copying the install directory from my D drive to my C drive thinking that this would somehow magically solve all the issues, I noticed an oddly named file in the directory. It was called "NetAdvantage_Installation_Notes.htm". Interesting...couldn't hurt to read THAT file now could it?

Mmmhmm...you can guess how this ends. The solution was there all along, just hidden in the ReadMe file that I totally passed off on. Learn from my mistakes, and RTFM.

So onto the solution. Turns out that the controls need to have two things in place:

1. UAC Turned Off (which I already have, so no worry there).

2. IIS 6 Management Compatibility checked (which I didn't have)

Once I had the IIS 6 stuff installed, the Infragistics install went without a hitch. Booya.

D




Feedback

# re: Infragistics Installation on Vista

I don't know about the web controls but the WinForm controls seem to like trying to write to protected memory and causing Visual Studio to crash. Of course this only happens when you try to view a form or custom control in design mode, so it's only irritating to...well...everyone. 7/9/2007 8:49 AM | Donald Belcham

# re: Infragistics Installation on Vista

Thanks for that! Did the same mistake! 9/15/2007 10:37 PM | Henrik

# re: Infragistics Installation on Vista

I only wasted about 45 minutes trying compatibility modes, etc. on Win 7. Thanks for the help, man. Your tip worked great. 3/31/2010 11:03 AM | Tom Puleo

Post a comment